Forum Navigation
Forum breadcrumbs - You are here:ForumForums: Questions & AnswersHoming speed
You need to log in to create posts and topics.

Homing speed

12

Hey boys - This is a lathe. I have the Masso homing nicely but the speed between X and Z is painful. X homes well but Z is a crawl (I mean a real crawl. You can hardly see it moving). And with a 30 inch bed it takes 5 minutes.

If I up the homing speed for both the X over travels (6 inch travel) and hits the hard stop.

Axis calibration has been completed for X & Z.

Is There a solution to this?

Cheers

Uploaded files:
  • CNC-Lathe.jpg
  • MASSO-homing-speed.jpg

10 inches per minute is slow

I return at 100 inches per minute

but you have to ensure your steps will allow that

Ray

@westyone

another suggestion is to make sure that the X axis prox. If your using a prox is set pretty close to the target so it sees it good and early. Then you can bump the speed up

Guy

seems like your loosing steps? your Z axis is the heavier of the two so knowing the type of motors and size of them might offer some more clues. could be just a tuning issue on the Z axis or it could be undersized or even under powered and not getting to if full potential if they are running on a small DC power source if it is a DC system even? need some more information to offer anything better than a guess and what my gut thinks 🙂

@westyone

Have you tried increasing the acc and dec setting on the axis page? Not sure if this will help.

Josh

Thanks for the input guys - This is an 80v 6amp twin driver system connected to NEMA34 steppers. The pitch of the lead screws are different between Z & X but I expect the calibration wizard found that.

Both stepper motor drivers are set at 400ppm. The X axis rattles like hell during Homing but smooth after that, Z is perfectly quite?

Must be a driver to Masso configuration glitch.

Back to settings I go.

Regards

could always put an indicator  and check to make sure the machine s moving what the controller tells it to move to double check things.

Hi Westyone

Try setting your X axis maximum speed in the X axis settings page to 10 ipm and leave your Z axis at it's high speed setting.

Then set your homing speed to one that suits the Z axis but the X axis should still only move 10 ipm. There is no need for such a short axis to move at high speed as it will be uncontrollable if you are moving it by hand

Hope this helps

Cheers

Peter

@westyone whats your micro-stepping settings for both motors?

Quote from MASSO Support on August 14, 2019, 11:40 am

Hi Westyone

Try setting your X axis maximum speed in the X axis settings page to 10 ipm and leave your Z axis at it's high speed setting.

Then set your homing speed to one that suits the Z axis but the X axis should still only move 10 ipm. There is no need for such a short axis to move at high speed as it will be uncontrollable if you are moving it by hand

Hope this helps

Cheers

Peter

Thanks Peter. That does work.

Cheers

12