Forum Navigation
You need to log in to create posts and topics.

Program stopping randomly

Hi I have an issue where the program I am running will stop at random times and random places within the program.

Here is a picture of the electrical box

IMG_1285.JPG

Here is the program

( Round )
G40
G80
G90
G54
G64
G00 X0.
Y0.
G91
G01 Z90. F4000.
G90
M8
G01 X11. F200.
X21.5 F300.
G00 X6.7188
G03 X1.7813 Y-4.9375 I0. J-4.9375 F100.
G00 Y0.
X6.7188
G02 X1.7813 Y4.9375 I0. J4.9375 F100.
G00 X0. Y0.
M30
%

FYI the Z axis is actually a rotary table and the feed rate translates to approx. 3,5 deg/sec.

See anything here that might help?

Guy

 

 

Nice looking machine evermech. Not sure what you are making but it's interesting to see.

Looking at the Gcode there are 2 pieces of unsupported GCode. G40 and G64 that you could remove. Other than that the Gcode looks ok.

What do you see on the screen when the machine stops? Are you seeing an alarm?

You can press the print screen button on your keyboard and it will dump a copy of the screen to the USB stick. It might give a clue.

You have quite a few inputs wired up. Could any of these be tripping to cause the machine to stop?

What do you have to do to restart the machine? Does it need to be repowered or does pressing CTRL+S continue the machining?

Cheers

Peter

 

 

Hi Peter

No alarms all is well on the screen when it stops. There are no alarms on any of the servo drives.

The inputs are 3 homing prox's, X,Y,Z.A alarms, Cycle start, and Home. No problems with any of them.

I had a servo alarm once due to a mechanical condition and the Masso detected it and displayed it, so I know the

alarm circuits are correct. Do you think I could be getting some EMI in the box? The 3 servo drives are in the bottom left corner.

I have the customer power off then restart and home from scratch just to insure that it is in the proper position, I don't have a lot of

room for error as it works around the clamping fixture. If I am around when it stalls, and the machine is in its proper G54 start position

I can reload the file and it will go. That's telling me its not losing its home position. It kinda feels like a communication issue with the stick.

I will edit the G code tomorrow just in case.

Guy

Quote from evermech on June 19, 2019, 6:18 am

It kinda feels like a communication issue with the stick.

I did have some problems with some usb-drives.  Did you try to replace it with a different kind?

Also I see no point with G80 (Cancel Modal Motion) in this program. Maybe you should remove that line too when you're at it.

@jolbas

Thanks for the tips I will rempve the G80 just in case ots causing trouble.

What usb drive did you end up using? I have tried a Lexar and am now using a Verbatim

Guy

Had problems with no brand and several Kingston. But no problems with any of the Sandisk drives so far. Haven't tried any Lexar or Verbatim.